Loading Issues

Major incident CORE FUNCTIONALITY Autoresponders Delivery Status Notifications Escalation Group messaging Inbound messaging Outbound messaging P2P messaging INTEGRATIONS Angi Clio Constant Contact FranConnect HelpScout Hubspot Mailchimp Microsoft Dynamics 365 Mindbody Pipedrive Quickbooks SharpSpring Shift4Shop Square VoteBuilder Zapier Zipwhip Migration Tool CORE CONNECTIVITY Core Connectivity
2026-06-06 09:07 EDT · 3 hours, 11 minutes

Updates

Monitoring

Our team has implemented a fix and Text Request should again load as expected. We are continuing to monitor for platform stability.

June 6, 2026 · 10:28 EDT
Investigating

Our team has been alerted that users may be experiencing loading issues when attempting to access Text Request. We are actively investigating and will post all updates here.

June 6, 2026 · 09:07 EDT

← Back