Group Message Delays

Minor incident CORE FUNCTIONALITY Group messaging
2026-03-31 10:24 EDT · 17 minutes

Updates

Resolved

All delayed group messages have been or are currently sending. We will continue to remain vigilant and monitor for any further disruptions.

March 31, 2026 · 10:40 EDT
Monitoring

We are observing group message speeds returning to normal. At this time we are continuing to monitor the situation.

March 31, 2026 · 10:34 EDT
Issue

Currently we are seeing some group messages taking longer than expected to send. We are investigating at this time.

March 31, 2026 · 10:24 EDT

← Back