Group and Compose Message Delays

Major incident CORE FUNCTIONALITY Autoresponders Delivery Status Notifications Escalation Group messaging Inbound messaging Outbound messaging P2P messaging
2026-02-24 11:12 EST · 13 hours, 6 minutes

Updates

Resolved

Our team is continuing to work on resolving the issues resulting in message delays.

Please refrain from attempting to send group messages at this time, as they will not send.

February 25, 2026 · 00:19 EST
Investigating

We can report that Compose messages are operating as normal, however we are still working to resolve some issues with Group messages.

February 24, 2026 · 20:17 EST
Investigating

We continue to work on a resilient and full resolution. Currently Group Messages are still unable to be processed as we work through the issue.

February 24, 2026 · 17:19 EST
Investigating

Our team is continuing to work on resolving the issues resulting in message delays.

Please refrain from attempting to send group messages at this time, as they will not send.

February 24, 2026 · 15:50 EST
Update

We remain actively working to resolve this issue. More updates to follow.

February 24, 2026 · 15:09 EST
Update

Our teams continue to work to resolve the issue causing messaging delays.

February 24, 2026 · 14:02 EST
Investigating

Our team is investigating an issue impacting group and compose message delivery that is resulting in delayed sending.

February 24, 2026 · 11:12 EST

← Back